To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Pattern Abstractions visualizer/plugin

edited September 2011 in - Usage

I'm currently working my way through the ProM 6 tutorial pdf (, but I'm struggling with section 3.2 (Mining Case-Related Information about a Process). I'm told to select the "Pattern Abstractions" visualizer from the drop down list, but I only have the following options: "Log Visualizer", "Show Sequences and Patterns" and "XLog Overview". I've tried selecting "Show Sequences and Patterns", but the interface shown there and options provided to not correspond with the ones described in the pdf.

I've looked in the package manager and have the PatternAbstractions 6.1.12 plugin installed. I'm using the normal (not nightly) build of ProM 6.1, on a Linux system.

Thanks in advance.


  • Hi Macuyiko,

    Can you please reinstall the package(s) by doing the following:

    (i) delete your .ProM folder in your home directory or
    (ii) edit the following lines in the ProM.ini file:
     PACKAGE_FOLDER = packages => PACKAGE_FOLDER = ./XXXXX/packages (you can give any name to XXXXX)
    WORKSPACE_FOLDER = workspace => WORKSPACE_FOLDER = ./XXXXX/workspace
    the Package Manager and install the package(s). Upon successful
    installation of the PackageAbstractions package, you should now see
    "Pattern Abstraction (New)" in the log visualizer options. This contains
    the latest implementation of the plugin.

    Let me know if this helps.

    Kind Regards,

  • Still no luck after reinstalling PackageAbstractions (and all other packages for that matter). I've tried setting ProM's verbosity to "VERBOSE", and PatternAbstractions is being processed, scanned, added to the classpath and found in cache, but it does not show up in ProM.

    I've also tried installing ProM (both the normal and nightly builds) on another Windows machine, and experienced the same problem. To make sure I'm really looking in the right place (and to avoid possible further embarrassment), I've attached a screenshot of where I'm looking.

    Kind regards,
  • Hi Macuyiko,

    There was a dependency which was not specified for the package manager during installation. It was a mistake on my part. We have fixed the issue now. Please reinstall the package using ProM6.1 release (it is safer to delete your .ProM61 folder in your home directory before installation).

    Now it should work. In case you still encounter the problem, please clear the contents of the following registry key (using regedit):


    (Prom scans for installed plugins in the specified registry entry). Reinstall ProM6.1 after clearing the contents of the registry key mentioned above.

    Let us know whether this helps. Sorry for the inconvenience.

    Kind Regards,


  • Hi jcbose,

    I've tried reinstalling ProM 6.1 under Windows, and now the plugin indeed appears - thanks! Under Linux however, I've not managed to make the plugin work (I've tried re-downloading ProM, re-installing packages and removed my .ProM61 directory).

    Is there an entry somewhere in Linux (corresponding with the registry key) I can try clearing?

    Kind regards,
  • Hi Macuyiko,

    Do you see any messages at the console when you execute ProM.bat (on linux)? If so, can you post them for us to diagnose?

    Kind Regards,
  • I do. I've attached both the stderr and stdout messages here (using verbosity ALL). Let me know if I can provide anything else.
  • Hi Mcuyiko,

    Looking at the two attachments, I find that there are no errors or abnormality. You may want to clear the contents in the registry equivalent on linux. It should be stored in $HOME/.java/.userPrefs (please browse through this file/folder or $HOME/.java) for process mining related file/folder and clear it (I haven't tried installing ProM on linux and hence do not know the exact file location; but it should be stored somewhere in these two folders).

    You need to reinstall ProM after clearing the contents.

    Hope this helps.

    Kind Regards,
  • Macuyiko
    edited September 2011
    Hi jcbose,

    I've cleared ~/.java/.userPrefs and reinstalled the packages. The Pattern Abstractions plugin now appears as it should.

    Thanks again for your help,
Sign In or Register to comment.