To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Problem after download the Prom Using SVN in Eclipse

Atfer download the ProM and try to run in eclipse this message occurs. I alread try to ownload it using TortoiseSVN unsuccessfully.
Can someone help me?



  • Hi,

    It seems that the internet connection you;re using does not allow ProM to retrieve the packages in time. At least, ProM tried for 128 milliseconds, but this was not sufficient.

    In the ProM.ini file, please add the following lines:
    This will prevent ProM from using any timeouts while retrieving packages. Note that as a result ProM may wait forever for a package to arrive. A more prudent approve would be:

    READ_TIMEOUT = 60000
    This sets both timeouts to 60 seconds.

    Kind regards,


  • Thanks Eric,

    Using this lines, the download started and then the ProM are initialized but no plugin are available. I was hoping that all plugins would be available. 

    I put two images:

     first image are about the started ProM after run "ProM Package Manager (Workshop).launch" and,
    second imagem are about the folders and files that have been downloaded .



    I need the conformace plugin code to understand the metrics that are generated.
  • Hi,

    Could you please update your local working copy from the repository? I've made some additional changes to the ProM.ini file, and updated some other things as well.

    The Workshop package had not been updated for a while, which caused it to look for a package that did not exists anymore. Should be ok again now.

    Nevertheless, if this still fails for some reason, please include the text from the Eclipse Console (like in your first screenshot), as this the most detailed information on what ProM was doing.


  • rosangelamariah
    edited February 2018
    Thanks Eric,
    I tried to update your local working copy from the repository, but another error have been produced, as you can see in image.

    I tryed include the text from the Eclipse Console but this error show in it:
    Erro: Could not find or load main class org.processmining.tests.framework.PromFrameworkTest

  • Hi,

    Now you've got me puzzled. Are you now checking out the folder "" into your Workshop folder? I do not see where the XTract folder is coming from, certainly not from the Workshop package... The earlier screendumps also do not show this XTract folder. And the main class you mention also does not ring a bell.

    If you right-click the Workshop project in Eclipse, and select Properties and then Subversion, what is then the Url that is shown? Should be



  • Hi Eric, Thanks!
    Yes, the url is "".
    After remove and reinstall the error from xTract did not appear anymore and this running ok.
    Unfortunatly I did not find the package that contain the java code plugin for conformance analisys. Could you help me find it?



  • Dear Rosângela,

    Thanks for letting us know.

    The "Replay a Log on Petri Net for Performance/Conformance Analysis" plug-in can be found in the PNetReplayer package, which can be checked out from

    If you simply want to run the plugin, please make sure that the PNetReplayer package is installed (use the ProM Package Manager to install it, if needed).



Sign In or Register to comment.