To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Unable to run Inductive Visual Miner [Java-RuntimeException|

Hi All, 

With both ProM and ProM lite (in the latest versions available), I load the Event Log with no problems and everything seems to work fine. However, when I try to run the Inductive Visual Miner on the Event log I get this error message. 

       Unable to produce the requested visualization

Error Message

java.lang.RuntimeException: Graphviz-dot binary not found. 

 Please find the image attached. 


  • Hi,

    one possible reason is that the dot.exe file is missing for somehow. Please try to remove the \dotBinaries7 directory, and run the ProM and the plugin again.

    Hope this helps.
  • CongLiu said:

    one possible reason is that the dot.exe file is missing for somehow. Please try to remove the \dotBinaries7 directory, and run the ProM and the plugin again.

    Hope this helps.
    I had the same problem and this worked, thanks!
  • Where can I find the \dotBinaries7 directory on a Mac?
  • hverbeek
    edited September 2019
    As a result of the former, if you want ProM to recreate these files, just remove the entire .prom-graphviz folder.
  • Hi Frank,

    You can find the latest dot binaries as used by ProM (including the Inductive Visual Miner) in the folder <>/.prom-graphviz. If is not explicitly set, it will have a default value, like /tmp. However, different systems may return different folders, so it is hard to say which folder it is exactly in.

    You can set to some folder (like /tmp) by adding the following snippet to the line that starts the ProM VM:<br>
    Then you know that the dot binaries are in the/tmp/.prom-graphviz folder.

    Note that ProM will copy the files into that folder when it detects that these files are not there yet.

    Kind regards,

  • hi all

    I got the same problem . I run proM13 on a Mac, when I use inductive visual miner ,proM quit.

    I try Frank's way to solve this problem,but I still can't find the file on my Mac.

    and the VM for proM on my Mac, return as below:

    Start plug-in Mine with Inductive visual Miner

    End plug-in Mine with Inductive visual Miner, took 0 milliseconds

    Start plug-in Inductive visual Miner

    2023-09-21 10:53:59.471 java[37560:2971669] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'NSWindow drag regions should only be invalidated on the Main Thread!'

    *** First throw call stack:


     0  CoreFoundation           0x00007ff81541c18a __exceptionPreprocess + 242

     1  libobjc.A.dylib           0x00007ff814f4242b objc_exception_throw + 48

     2  CoreFoundation           0x00007ff8154442f6 -[NSException raise] + 9

     3  AppKit               0x00007ff818465e7e -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 307

     4  AppKit               0x00007ff818452394 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1227

     5  AppKit               0x00007ff818451ec2 -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42

     6  libnativewindow_macosx.jnilib    0x00000001a0c5f3fe Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398

     7  ???                 0x000000010d849747 0x0 + 4521760583


    libc++abi: terminating due to uncaught exception of type NSException

    ./ line 37: 37560 Abort trap: 6      $JAVA -Xmx4G -da -classpath ${CP} -Djava.library.path=${LIBDIR} -Djava.system.class.loader=org.processmining.framework.util.ProMClassLoader -Djava.util.Arrays.useLegacyMergeSort=true ${MAIN}

    looking forward for more advise, thanks

    Kind regards,


  • Hi Avril,

    I don't think this is a problem with dot. Other dot-related plugins may just work on your Mac.

    As from MacOS Catalina, some plugins in ProM (and ProM Lite) have stopped working. This is caused by the fact that these plugin require a 32-bit library to load, and MacOS has stopped support of 32-bit libraries as per Catalina. Unfortunately, we do not have a 64-bit version for Mac for that library, we do have them for Linux and Windows, but not for MacOS.

    Strane enough, however, I've seen recent Macs with recent MacOSs where the Inductive Visual Miner did just work. But apparently you're not lucky in this.

    Running ProM Lite in a (Windows) VM may be an option.

    Kind regards,


Sign In or Register to comment.