To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

"No connection between the given log and net"

edited June 2017 in - Usage

I want to get precision/generalization scores for my process model but keep getting the message "No connection between the given log and net". I do not know what exactly the problem is in such cases or how to fix it.

I have an event log which I filtered in Disco, removing some activities and cases which do not have a specific set of start/end points. The message occurs when i export the log in csv, xes, with/without adding endpoints. 

In Prom i use the inductive miner to get a petri net. And then use the combination in plugins such as : 

"Replay a log on Petri net for Conformance analysis"
"Partial aware replay"

I can use "partial advanced replay" conformance checking, but then with the plugin "Measure precision/generalization" i still get the same message.

I have added a picture with the error messages. 

Thanks already for the help in advance, 



  • Dear Saskia,

    Let's start at the beginning: Which version of ProM are you using?

    The picture only shows one error message: The "java.lang.NullPointerException" in the middle box. The other messages are informative.

    Note that for a replay there needs to be a connection of sorts between the model and the log: steps in the model should be linked to activities in the log. One of the dialogs that you need to fill for the replay is to create such a connection.

    Kind regards,

  • Dear Eric, 

    I am using ProM 6.6.

    When trying to use the plugins I mentioned, the message box shown in the picture below is the first and only dialog box that pop-ups. For the Partial advanced replayer the "create event class pattern", and "Map transition classes to patterns" dialogs open, which I assume you were referring to ? 
    If I then try to use the result from that replayer, it shows the message in the second picture.

    Kind regards,


  • Dear Saskia,

    That's odd, it works for me.

    Can you do the following:
    1. Start ProM PM 6.6 (the Package Manager for ProM 6.6)
    2. Clear the plug-in cache using the button in the bottom right corner
    3. End ProM PM 6.6
    4. Start ProM 6.6
    5. Try your scenario
    If this again fails, I would be interested in the messages generated by Step 4. For this reason, please start ProM 6.6 using the ProM66.bat file. This starts a Command Prompt which shows all messages. By right-clicking the Command Prompt and selecting "Edit / Select All" followed by hitting the Return/Enter key, you copy the messages to the clipboard. From there, you can paste it on this page, if needed.

    Kind regards,


  • Dear Eric,

    This has solved my problem, I can now properly use all these plugins again. 

    Thank you very much for your help! 

    Kind regards,

    Saskia v.Doormalen 
  • Dear Saskia,

    OK, thanks. For the sake of completeness, I'll add some comments here, as some others may experience the same problem, and then knowing what the problem is may help.

    When ProM starts, it knows almost no plug-ins. Only a few plug-ins are implemented in the ProM framework itself, most of them are implemented in the so-called packages. To get to know these plug-ins, ProM needs to scan all these packages for plug-ins. After this scan, ProM knows the plug-ins. However, this scanning takes some time. For this reason, we added a plug-in cache to the framework. As a result, ProM now only needs to scan a package once, after which the results are stored in this plug-in cache. In a next run, ProM will check the plug-in cache, see that the package has already been scanned, and use the cached information instead of scanning the package again. As a result, ProM will start much faster.

    So far so good, but now what if the first scan fails for some reason? Then the cached information is not correct. This is what happened in your case. According to the cache, some plug-ins did not exist in some packages, while in fact they did exist. To get around this problem, the Package Manager allows you to clean this cache. As a result, next time ProM runs, it will scan all packages again and rebuild the cache.

    Why in your case the first scan failed I cannot tell. Also note that after cleaning the cache the next scan may also fail for some reason. However, this is very rare. In your case, this did not happen :-).



Sign In or Register to comment.