To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

How to select the amount of memory ProM use

Hi every body,

I want to augment the amount of memory used by Prom. For this I used the configuration proposed in Prom package Manager. 

However, despite the amount of memory I choose (for instance, 3GB),  each time I open again the Prom Package manager, it always shows that the current amount of memory used by prom is 1GB.

Can you tell me if I am doing something wrong ?

Thank you.

Best regards.



  • Dear hicheur,

    Can you tell me which version of ProM you are using?

    Note that this setting only works in releases. For the nightly build, this will not work, and you will have to edit the .bat or the .sh file manually to change the memory setting. In this file, look for the "-Xmx" option, and change accordingly.

    Kind reagrds,

  • Hello Eric,

    I am using ProM 6.6 (it is not the nightly build version).

    Thank you.

    Best regards.
  • Hello hicheur,

    If you're using ProM 6.6, then there should be a file named ProM66.l4j.ini in the folder where you have installed ProM 6.6. If you open this with your favorite text editor, you will see something like this:
    -da -Xmx4G -XX:MaxPermSize=256m -Djava.library.path=.//ProM66_lib -Djava.util.Arrays.useLegacyMergeSort=true -DsuppressSwingDropSupport=false
    Please swap the "-da" and the "-Xmx4G" entries on this line:
    -Xmx4G -da -XX:MaxPermSize=256m -Djava.library.path=.//ProM66_lib -Djava.util.Arrays.useLegacyMergeSort=true -DsuppressSwingDropSupport=false
    Then it should work.

    The main memory setting for ProM is the one that is stored in this file. If you change the memory setting, then this will will be updated, together with the .bat or .sh file for ProM 6.6.

    However, ProM expects the memory option (-Xmx4G) to be the first on the line, which it is not. Swapping makes it the first on the line, which should solve the issue. This is a 'bug' in the ProM66.l4j.ini file.

    Kind regards,


  • Hi.

    Thank you Eric.

    I will try that.

    Best regards.
Sign In or Register to comment.