To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Converting .csv file to .xes

I downloaded some data from an ERP system and converted to .csv file. I am using 'Convert CSV to XES' plugin to convert .csv to .xes. However, I am getting the error as attached. Preview is also attached.
Can you help me to identify issues? There are 2 columns that has data type as 'discrete'. Is this a problem?



  • As mentioned in one of other forums, I started Prom by typing in 'ProM651.bat' from command prompt. Now I am getting below error for all the rows. 


    Skipping event, could not convert [348467, I, KEY, Start, 4151504211, 8.00E+12, EKKO, ME21, 1, 24/02/2003, RENDES, 15:55:44]
    Error: java.text.ParseException: Could not parse 24/02/2003
  • Hi Amar,
    do you still get the output NullPointerException in the ProM activity view? 
    I remember that there was a similar bug report a while ago, but I could not reproduce it.

    Would you be able to send me ( the event log? Of course, I will treat it as confidential data and delete it once I figured out what is going wrong. I assume the issue might be with the timestamps or the discrete columns, so you could only include those.

    Another option would be to try out the current nightly build:
    And see if the error has been fixed in the meantime.
  • Hello, I found couple of issues. If I do not import time/date, it works fine. Another thing to note is that name of the first column should not have a number.

  • Btw, i have already sent mail to your id.

  • Hi Amar,
    I received the file and I could find the bug causing the error. Thanks for your effort.

    I just fixed it and in a few hours there should be a new version of the Log package available for the nightly builds version.

    Unfortunately, I'm unable to fix it in the released version due to the ProM release policy.

    " I found couple of issues. [..] Another thing to note is that name of the first column should not have a number."

    I would be glad to hear of all the issues. I'm keen to fix them before the next ProM release. I don't understand what you mean with "name of the first column should not have a number".

  • Hi Felix,
    Thanks for the message. I am able to locate nightly version.
    How do I install and use nightly version?

    Regarding the other issue, if the first column name of the .csv file contains a numeric character, the conversion fails. For e.g., in the .csv file that I shared, has first column header as 'CHANGENR2'. I removed '2' from the header name and then it worked fine.

  • kkoopen
    edited March 2017


    I'm very interested in this problem, because I'm dealing with a very similar problem. When trying to convert my csv datafile into a xes log file I do get the same kind of error:

    Skipping trace 450011751400080, could not convert[880211731465080,
    (EKKO-EKPO) Purchase Order created, KENE, 1,494, 05.08.2015 00:00:00
    1,235.34, null, null, ST, 2200, 910B 50 5000 Parchet, 10650578, 12010874, USD, 1.07250, 1.81, null, null, null, null, null, null, null]
    Error: java.text.ParseException: Could not parse 05.08.2015  00:00:00

    As well as posted here, when not importing the date and time the import works fine. I used the following date Format() : dd.MM.yyyy HH:mm:ss.
    I hope somebody could help me out here, it would be very much appreciated!


  • Hi K,

    Did you investigate this line in the input data? Does the data format differ? Or are there other possible issues in this line in the data?
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
Sign In or Register to comment.