To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Missing Paths when using ILPMiner/HeuristicMiner, NullPointerException with AlphaMiner

edited October 2014 in - Usage

I am using RapidMiner 5.3 with ProM 6 to mine thousands of cases in a .csv File. I started with investigating two cases in detail, but in the petri net I am missing paths.

I attached a simplified example (Example.txt). In the first case, the order of the activities is A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U. In the second case, the order of the activities is A, B, C, E, D, F, V, G, H, I, J, K, L, P, N, M, Q, O, W, X, R, S, T, U. In RapidMiner I read the CSV-File, Convert it to an Exampleset, add an artificial start and end event, and then call the Miner.

I attached the result of the ILP-Miner in ILPMiner.png (only an extract). All required paths of the first case are shown, but for the second case, no path from N to M is included. After N, it is only possible to execute O (required for first case), as well as R and W (these paths are not necessary if only case 1 and 2 are considered).

I then used the HeuristicMiner, an extract is shown in HeuristicMiner.png. Considering the first case, no path is available from M to N, and considering the second case, no path is available from N to M. However, HeuristicMiner did not add additional paths.

Considering AlphaMiner, which worked yesterday, I was again missing a path from M to N in the first case, and a path from N to M in the second case. In addition, I had several duplicate paths, e.g., there were two paths from P to Q and from Q to R.

So I am not only missing paths in my petri net, I also have several additional paths I do not require. This is especially a problem when including more cases, e.g. when I used only 20 cases I had so many paths, that the petri net was not readable any more. Can you please tell me, if/what I am doing wrong or is there maybe a problem with the Event Log. Do I need further columns to make this example work? I appreciate every hint to a solution.

One further question: Yesterday my alpha miner worked, and after some minor changes, I only get NullPointerExceptions today. I tried to undo all changes but still get the following exception:
Oct 15, 2014 8:26:41 AM SEVERE: Process failed: operator cannot be executed. Check the log messages...
Oct 15, 2014 8:26:41 AM SEVERE: Here: Process[1] (Process)
subprocess 'Main Process'
+- Read CSV[1] (Read CSV)
+- ProM Context[1] (ProM Context)
+- Convert Exampleset into Log[1] (Convert Exampleset into Log)
+- Add Artificial Start and End Event Filter[1] (Add Artificial Start and End Event Filter)
==> +- Alpha Miner[1] (Alpha Miner)
Oct 15, 2014 8:26:41 AM SEVERE: java.lang.NullPointerException

Thank you very much,


  • After completely reinstalling RapidMiner and ProM, AlphaMiner is working again. Please find attachhed the missing screenshot of the AlphaMiner. Double paths are between P and Q, Q and O, and also between Q and R.

Sign In or Register to comment.