To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Pattern Abstraction Visualizer throws exception

edited January 2012 in - Usage
Hello all,

on chosing the Pattern Abstraction visualizer (new) from the drop down menu in the log view, an exception is thrown to stdout (see second attached file exception_extended.txt). In the GUI the display switches back to the object pool and probably there is an error message displayed in between but it happens so fast I cannot read anything. When I hit the View resource button on that log in the object pool I only see a white screen.

I use the current ProM 6.1 on MacOS X with the package patternabstractions-6.1.12.
(Both ProM 6.1 and the package downloaded and installed today).

Any ideas? I have tried chosing the Pattern abstractions visualizer on different log files.

Kind regards,

Best Answer

  • JBuijs
    Accepted Answer
    Hi Isabel,

    Thank you so much for sharing the cause of and
    solution for your problem! This helps others experiencing the same
    issues I'm sure!
    Happy process mining :)
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology


  • Took some time to debug it, but I found the cause of the exception. I thought I might share it:

    The log files I used were missing information about the lifecycle concept.

    Adding the elements
    <string key="lifecycle:transition" value="complete"/>
    to XES and
    to MXML log files did the trick.

    It also solved another Exception issue (thrown by Guide Tree miner plugin) on the same log files!
  • edgar
    edited September 2012
Sign In or Register to comment.