To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Unable to Launch ProM 6.1

edited September 2011 in ProM 6

I've just uninstalled ProM 6, and installed ProM 6.1 on my personal laptop. Unfortunately, I am unable to launch it.

When I launch (with and without admin rights) it normally (not within eclipse), the loading screen (the big green screen) appears, and disappears after that, without loading ProM. When I tried to launch ProM Package Manager, it loads, but there are no package displayed, nothing under all tabs (up to date/out of date/not installed/selection).

When I launch it within eclipse, this error occured:

WARNING: No configuration found for UITopia!
(This is okay if you start the application for the first time)
Creating new configuration file at C:\Profiles\XXX\UITopia\uito...
Exception in thread "main" java.lang.NullPointerException
        at org.processmining.contexts.uitopia.UI.main(

I've read the previous post about a similar problem at I understand that in his case, the problem is about his admin rights. But I've tried all the steps that are listed in the post, with and without admin rights, but none of them worked for me. I've also tried un-installing and re-installing ProM 6.1 to no avail.

Are there any other ways to make ProM runnable again on my laptop? Your help will be very much appreciated.

If this helps, the content of my packages.xml is:

<?xml version="1.0" encoding="iso-8859-1"?>

And, the content of my uitopiaconfig.xml is:

<?xml version="1.0" encoding="UTF-8" ?>
<!-- UITopia configuration file. -->
<!-- (c) 2009 by Christian W. Guenther ( -->
<!-- WARNING: Do not manually edit this file, unless you know what you are doing! -->
<configuration timestamp="1316575405477">
<set name="master">
<set name="org.processmining.contexts.uitopia.packagemanager.PMFrame">
<attribute key="window_height" value="750"/>
<attribute key="window_width" value="1024"/>
<attribute key="window_x" value="10"/>
<attribute key="window_y" value="10"/>
<set name="org.processmining.contexts.uitopia.packagemanager.PMMainView">
<attribute key="activeView" value="WORKSPACE"/>



  • Hi Keith,

    It seems that ProM crashes when starting up.

    Could you please open th efolder where you've installed ProM and try to run the ProM.bat file? First of all, this will bypass the splash screen :-), but it may also provide us with additional information on what the problem is.

    Did you have an internet connection when you tried to start ProM? Please check the PACKAGE_URL line in the ProM.ini file, and check whether you can access the package file listed on this line. Initially, ProM comes with only a few basic plug-ins, and when started up for the first time it will download the remaining packages from our package repository.


  • Hi Eric,

    I've un-installed and re-installed my Java, and somehow ProM can be launched, but it stuck at the download external packages page. It has been "downloading" for ages, and I didn't see any process nor any increase in file size (.ProM61 package folder). Below is the lines I got from running the ProM.bat file.

    C:\Program Files\prom-6.1>java -ea -Xmx1G -XX:MaxPermSize=256m -classpath ProM61
    .jar org.processmining.contexts.uitopia.UI
    WARNING: No configuration found for UITopia!
    (This is okay if you start the application for the first time)
    Creating new configuration file at C:\Users\Keith Low\UITopia\uitopiaconfig.xml.
    [PackageManager] Flex
    [PackageManager] PNAnalysis
    [PackageManager] DottedChart
    [PackageManager] SignatureDiscovery
    [PackageManager] PomPomView
    [PackageManager] BPMN
    [PackageManager] Replayer
    [PackageManager] CPNet
    [PackageManager] GeneticMiner
    [PackageManager] PetriNetReplayer
    [PackageManager] Petrify
    [PackageManager] Fuzzy
    [PackageManager] SocialNetwork
    [PackageManager] LogMetrics
    [PackageManager] Animation
    [PackageManager] OperationalSupport
    [PackageManager] Murata
    [PackageManager] TSPetrinet
    [PackageManager] OSService
    [PackageManager] LogMerge
    [PackageManager] YAWLReplay
    [PackageManager] Woflan
    [PackageManager] TransitionSystems
    [PackageManager] LpSolve
    [PackageManager] HeuristicsMiner
    [PackageManager] Cosimulation
    [PackageManager] ILPMiner
    [PackageManager] PetriNets
    [PackageManager] InteractiveVisualization
    [PackageManager] EPC
    [PackageManager] AlphaMiner
    [PackageManager] EPCConversion
    [PackageManager] Widgets
    [PackageManager] COSAImportExport
    [PackageManager] LTLChecker
    [PackageManager] Declare
    [PackageManager] Log
    [PackageManager] DeclareMiner
    [PackageManager] Grid
    [PackageManager] PatternAbstractions
    [PackageManager] Performance
    [PackageManager] MoBuConLTL
    [PackageManager] GuideTreeMiner
    [PackageManager] XQueryProvider
    [PackageManager] LogAbstractions
    [PackageManager] CTLStar
    [PackageManager] Uma
    [PackageManager] ServiceTech
    [PackageManager] LogDialog
    [PackageManager] LogTimeFrame
    [PackageManager] KeyValue
    [PackageManager] TraceAlignmentWithGuideTree
    [PackageManager] ETConformance
    [PackageManager] ConceptDrift
    [PackageManager] Clustering
    [PackageManager] AProMore

    I've also checked the PACKAGE_URL line, and I'm able to access their XML and download their package. I've tried installing it in other computers and it works fine, I'm not too sure why my computer isn't able to run it.

  • Jazmina7
    edited November 2011
    How do I run a .jar executable java file from outside NetBeans IDE? (Windows Vista). My project has a .jar file created by Netbeans. We'd like to run it. Either: how do we run the file or how do we create a 'proper' executable file in NetBeans 6.1?
  • Hi Jazmina7,

    Welcome on the ProM forum!
    Is your problem related to ProM?

    I think that if you search for your problem that you will find a lot of websites and explanations on how to achieve what you are trying to do.

    Good luck!
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
Sign In or Register to comment.