To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Problem to get ProM to run from source in eclipse

edited September 2011 in - Development
Hi all!

I’ve just downloaded ProM from the repository. I used the tutorials and to check out and to run the ProM.

There are no errors in the workspace. However, when I try to get ProM to run, using “ProM with UITopia” run configuration, the User Interface did not get visible. I tried to debug in order to find the problem and I realized that the program got stuck in the loop “while (!installed.isEmpty()) {” at line 280 in the class “”. So I tried changing the “while” to an “if” statement. The user interface then got visible, but many exceptions were thrown and the ProM framework appears not working well.

Could someone help me to fix that problem ? Thanks in advance.

Salomao Madeiro


  • Dear Salomao,

    Were you connected to the internet when you tried to start ProM?

    Your ProM download contains only the ProM framework, no packages are included. When you start ProM for the first time, it will try to download all required packages. Of course, this requires an internet connection.

    If you were connected to the internet, there could have been a problem with the package repository file. Apparently, some packages failed to install, most likely due to cyclic references. Could you please post the contents of your ProM.ini file? This should contain the URL to the package repository you're actually using. Also, the contents of this installed variable could give a clue to where the problem is. As you were already debugging, perhaps you could check which packages ProM could not install?


  • Dear Erik,

    Thanks for your reply. Yes, my computer was connected to the internet when I tried to run ProM. Only for your information, I’m using Win7 (64 bits), Eclipse (Indigo release), Java version 1.70 (64 bits).

    As you suggested, I debugged ProM again. For the “while” loop I mentioned in the previous message, there were initially 47 packages in the variable named “installed”. After three iterations, only the package named “BPM2010-1.1” was still in the set. Right bellow, I put more details about that package. Because it was not possible to remove it from the set, the program got stuck in the loop “while (!installed.isEmpty()) {” at line 280 in the class

    package name: BPM2010-1.1
    url: url:
    description: ProM 6.0 BPM 2010 release wrapper (windows 64bit)
    dependencies: [Wendy, Workload, PNAnalysis, DottedChart, TSAnalyzer, SignatureDiscovery, BPMN, TSMLImportExport, GeneticMiner, PetriNetReplayer, Abstractions, Petrify, Fuzzy, PNMLImportExport, SocialNetwork, PetriNet2EPC, SimpleLogFilter, Murata, TSPetrinet, TraceAlignment, LoLA, Woflan, PerfMeasurement, LpSolve, HeuristicsMiner, TPNImportExport, ILPMiner, AAPDiagram, Petri Net API, LogInsertStart, SPDiagram, AlphaMiner, CPlex, COSAImportExport, LTLChecker, DeclareMiner, PomPom, Performance, TestBed, TransitionChecker, GuideTreeMiner, PNUnfolding, LogAbstractions, XPDLImportExport, EPMLImportExport, ServiceTech, LogDialog, TSMiner, ETConformance]
    conflicts: []

    I copied the content of the ProM.ini file in the end of this email. Please, let me know it you need more details about that problem. Thank you again.

    Salomao Madeiro

    # This file contains information about this ProM release
    # it points ProM to the right packages and keeps version
    # information
    # Folders should be separated using "/" (forward slash).
    # This will be replaced with File.Separator().
    # Specifies the ProM release version
    PROM_VERSION = 6.1.0
    # Specifies which package should be installed
    RELEASE_PACKAGE = AllPackages
    # Specifies the URL to the default package repository
    # (default is "")
    # Specifies whether ProM is Verbose
    # (possible: "ALL" / "ERROR" / "NONE", defaults to "ALL")
    # The library folder is relative to the prom installation
    # folder (default is "lib")
    LIB_FOLDER = lib
    # The images folder is relative to the prom library
    # folder (default is "=images")
    IMAGES_FOLDER = images
    # The macro folder is relative to the prom library
    # folder (default is "macros")
    MACRO_FOLDER = macros
    # The prom user folder is NOT relative to the
    # prom installation folder. The (default is empty, in
    # which case the OS handles the location)
    # The package folder is relative to the
    # prom user folder. The (default is "packages")
    PACKAGE_FOLDER = packages
    # The workspace folder is relative to the
    # prom user folder. The (default is "workspace")
    WORKSPACE_FOLDER = workspace
    # Indicate whether or not ProM should serialize the
    # workspace. If switched off, the last serialized
    # workspace will be loaded on each start
  • Problem solved. I just set the correct place of my workspace as the value for the property PROM_USER_FOLDER in the ProM.ini file.
  • I followed same procedure of checking out and running from source. 
    All went fine but when I run Prom with UITopia, it gives me following error.

    'Could not find or load main class org.processmining.contexts.uitopia.UI'

    Can you please help me out of this??
  • JBuijs
    edited December 2011
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • Thank you!

    I have used exactly same links for checking out and Running Prom 

    But I don't know what to write in PROM_USER_FOLDER variable in  ProM.ini file.
    Is it causing  error that I have mentioned above?
    'Could not find or load main class org.processmining.contexts.uitopia.UI'


  • The PROM_USER_FOLDER has no influence on the error message you are reporting.

    Have you checked the solutions provided to other similar problems, as asked and answered on this forum?
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • Thanks Joos.

    I checked out UITopia instead of Framework, it worked fine. And when I checked out XESame it too ran fine.
    But when I checked out Framework according to tutorial and 'ran Prom with UITopia' from Eclipse, error remained. 

    Best Regards,
  • Hi Rabia,

    You should not check out the framework itself, that will not work probably.
    However, you should check out the trunk folder of a package (preferably one that you're interested in or are investigating). This will include the latest release of the framework.
    Joos Buijs

    Senior Data Scientist and process mining expert at APG (Dutch pension fund executor).
    Previously Assistant Professor in Process Mining at Eindhoven University of Technology
  • Thank you Joos. 
    I now fully understand this.
    Earlier I followed these two tutorials in sequence, which guided me to checkout framework:

    You may also bring it in the notice of other developers if its not the correct way to start.

    Best regards,
  • I have followed the instructions on I have the Workshop project without any errors on my Eclipse but when I try to run the ProM PM by selecting "ProM Package Manager (Workshop).launch" nothing happened. Could someone help me? I have tried to change the PROM_USER_FOLDER because it has solved the problem for salomaosm, but I'm still got nothing.

  • Hi,

    Would it be possible to post some details as provided by the Console in Eclipse? Are there any messages written to that Console?

    I can start the Package Manager from that project without problems.

    Kind regards,
  • This is the major problem, I didn't receive any error messages. The console just shows the process is terminated. I have recorded a video showing that ( I didn't change the configuration to run the PM, so it is like this:

    Main Class: org.processmining.contexts.uitopia.packagemanager.PMFrame
    VM arguments: -ea -Xmx1G -Djava.library.path=.//lib;.//stdlib

    I have also tried to run it from the command line, but I've got nothing, no error, but no Prom PM window. If you have any hints please.


  • Hi Denise,

    As far as I can see, it does not even start the Java VM which runs ProM. Please check your Java settings. If need be, select another JRE for running this.

    This, you can do as follows:
    1. Select the small downward arrow next to "run" symbol in the button bar at the top of the screen. This is the green round button with the white triangle in it. By clicking the small downward arrow, you get a dropdown menu.
    2. From this menu, select "Run Configurations...". This opens a dialog to change the run configurations.
    3. In the list on the left, select the "ProM with UITopia (Workshop)" configuration.
    4. At the right, select the "JRE" tab. This shiws the current JRE to use. Typically, this is set to the Project JRE. You might want to change this.
    5. Select "Alternate JRE", and choose a JRE from the dropdown list. If need, be, look for additional JREs usign the "Installed JREs..." button.
    6. Select "Run" to run ProM with the new configuration.

    Please let me know whether this helps.

    Kind regards,

  • Hello Eric,

      Thank you very much for your help. The project was running (I was just not seeing it), it was downloading the packages, and the console does not show anything because the Running configuration was set to use javaw, which ommits the console logs. I changed this in the eclipse by changing the running configuration and could see the messages in the console window. Sorry for my mistake and thanks again...

    Kind regards,
  • Hello Denise,

    Thanks for letting me know. The odd thing is, that I'm also using javaw, and still get the lines in the console... Perhaps a difference in Java versions, I do not know.

    Kind regards,
Sign In or Register to comment.