To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Error occurs when I use Ivy to resolve dependencies


When I want to modify the EarthMoversStochasticConformanceChecking plugin, I use Ivy to resolve dependencies. But an error occurs. The detailed error output is:

Some projects fail to be resolved

Impossible to resolve dependencies of prom#EarthMoversStochasticConformanceChecking;latest

unresolved dependency: prom#ProM-Plugins;latest: not found

unresolved dependency: prom#BasicUtils;latest: not found

unresolved dependency: prom#LpSolve;latest: not found

unresolved dependency: prom#GraphViz;latest: not found

unresolved dependency: prom#StochasticPetriNets;latest: not found

unresolved dependency: prom#StochasticLabelledPetriNets;latest: not found

unresolved dependency: prom#Widgets;latest: not found


The ivy.xml file:

<ivy-module version="2.0">

  <info organisation="prom" module="EarthMoversStochasticConformanceChecking" revision="latest">


   Version VERSION




   <conf name="default" extends="lib" />

   <conf name="lib" />


  <dependencies defaultconf="default">

   <!-- ProM dependencies. -->

   <!-- Please put every ProM dependency on a single line. -->

   <!-- ProM framework. -->

   <dependency org="prom" name="ProM-Plugins" rev="latest" changing="true" transitive="true" />

   <!-- ProM packages. -->

   <dependency org="prom" name="BasicUtils" rev="latest" changing="true" transitive="true" />

   <dependency org="prom" name="Widgets" rev="latest" changing="true" transitive="true" />

   <dependency org="prom" name="LpSolve" rev="latest" changing="true" transitive="true" />

   <dependency org="prom" name="StochasticPetriNets" rev="latest" changing="true" transitive="true" />

   <dependency org="prom" name="StochasticLabelledPetriNets" rev="latest" changing="true" transitive="true" />

   <!--<dependency org="prom" name="StochasticLabelledPetriNets" rev="latest" changing="true" transitive="true" />-->

   <dependency org="prom" name="GraphViz" rev="latest" changing="true" transitive="true" />

   <!-- Third party libraries. These may span multiple lines. -->

   <!-- Please uncomment the second line in the resolve target in your build.xml file

      if you have any third party libraries. -->

  <!-- Third party library downloaded from maven repository. -->

   <!-- dependency conf="lib->default" org="org.reflections" name="reflections" rev="0.9.10" /-->

   <!-- Third party library downloaded from ProM library. -->

   <!-- dependency conf="lib->default" org="prom-libs" name="opencsv" rev="2.4-patched" transitive="false" /--> 



Best Answer

  • hverbeek
    Accepted Answer


    I think the problem is signaled in this line:

    :: loading settings :: url = bundleresource://432.fwk1227520005/org/apache/ivy/core/settings/ivysettings.xml

    This indicates that you have selected an odd ivysettings.xml file for the EarthMoversStochasticConformanceChecking package. This ivysettings.xml amy not have the links ot our ProM repository. I would expect the path to the ivysettings.xml file of the package here.

    Perhaps good to remove the Ivy dependency management firs tfrom th epackage, and then add it again but now with the correct files.

    Kind regards, Eric.


  • Hi,

    Can you check whether you can access the URLs and in your favorite browser? These would be the URLs that ProM needs to visit for resolving the ProM-Plugins package. Similar for the other packages.

    Kind regards, Eric.

  • Hello Eric,

    I can access these URLs in chrome. Also I have a project that I can use ivy correctly, which ivy console outputs:

    [IvyDE] Initializing container org.apache.ivyde.eclipse.cpcontainer.IVYDE_CONTAINER/?project=Workshop&ivyXmlPath=ivy.xml&confs=*&ivySettingsPath=ivysettings.xml&loadSettingsOnDemand=false&ivyUserDir=&propertyFiles=

    [IvyDE] Unable to get the Ivy nature of the project EarthMoversStochasticConformanceChecking (org.eclipse.core.internal.resources.ResourceException: Project 'EarthMoversStochasticConformanceChecking' is not open.)

    :: loading settings :: file = C:\Users\Spylft\Desktop\Conformance_Sketching-master\IncrementalPM\ivysettings.xml

    [IvyDE] Resolve job starting...

    [IvyDE] Processing resolve request ivy.xml[*] in IncrementalPM

    [IvyDE] Settings has changed, configuring Ivy again

    :: loading settings :: file = C:\Users\Spylft\Desktop\Conformance_Sketching-master\IncrementalPM\ivysettings.xml

    [IvyDE] 1 module(s) to resolve outside the workspace

    [IvyDE] Resolving ivy.xml[*] in IncrementalPM

    :: resolving dependencies :: prom#IncrementalPM;latest

    confs: [default, lib]

    found prom#ProM-Plugins;latest in prom

    found prom#Log;latest in prom

    found prom-libs#OpenXES;20211004 in prom-libs

    found prom#ApacheUtils;latest in prom

    found com.univocity#univocity-parsers;2.2.2 in maven2

    found org.xerial#sqlite-jdbc;3.15.1 in maven2

    found com.googlecode.cqengine#cqengine;2.7.1 in maven2



    But in the failed ivy usage, the ivy console outputs:

    :: loading settings :: url = bundleresource://432.fwk1227520005/org/apache/ivy/core/settings/ivysettings.xml

    [IvyDE] Resolve job starting...

    [IvyDE] Processing resolve request Trunk/ivy.xml[*] in EarthMoversStochasticConformanceChecking

    [IvyDE] 1 module(s) to resolve in workspace

    [IvyDE] 1 container(s) of module module: prom#EarthMoversStochasticConformanceChecking;latest status=integration publication=Fri Mar 17 17:57:38 CST 2023 configurations={default=default, lib=lib} artifacts={default=[prom#EarthMoversStochasticConformanceChecking;latest!EarthMoversStochasticConformanceChecking.jar], lib=[prom#EarthMoversStochasticConformanceChecking;latest!EarthMoversStochasticConformanceChecking.jar]} dependencies=[dependency: prom#ProM-Plugins;latest {default=[default]}, dependency: prom#BasicUtils;latest {default=[default]}, dependency: prom#Widgets;latest {default=[default]}, dependency: prom#LpSolve;latest {default=[default]}, dependency: prom#StochasticPetriNets;latest {default=[default]}, dependency: prom#StochasticLabelledPetriNets;latest {default=[default]}, dependency: prom#GraphViz;latest {default=[default]}] to resolve in workspace

    [IvyDE] Resolving Trunk/ivy.xml[*] in EarthMoversStochasticConformanceChecking

    :: resolving dependencies :: prom#EarthMoversStochasticConformanceChecking;latest

    confs: [default, lib]

    :: resolution report :: resolve 9062ms :: artifacts dl 0ms


    | | modules || artifacts |

    | conf | number| search|dwnlded|evicted|| number|dwnlded|


    | default | 7 | 0 | 0 | 0 || 0 | 0 |

    | lib | 0 | 0 | 0 | 0 || 0 | 0 |


    :: problems summary ::

    :::: WARNINGS

    module not found: prom#ProM-Plugins;latest

    ==== local: tried


    -- artifact prom#ProM-Plugins;latest!ProM-Plugins.jar:


    ==== shared: tried


    -- artifact prom#ProM-Plugins;latest!ProM-Plugins.jar:


    ==== public: tried

    -- artifact prom#ProM-Plugins;latest!ProM-Plugins.jar:

    module not found: prom#BasicUtils;latest



    I think the main problem is in the failed one it tries to find the module in instead of But I don't konw how to fix it.

    There is these two ivy files, including ivysetting.xml and ivy.xml.

    Can you give me some precious advice?


  • Hi Eric,

    I solved this problem!

    In Window-Preferences-Ivy-Settings, I modified the Ivy settings path with the one in Workspace. Restart to resolve the dependency. And it works!

    Thanks for your help!

  • Hi,

    Yes, after I modify the ivy-setting file, it finally worked.


Sign In or Register to comment.