To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

RapidProm java errors

Hello colleagues,

I am testing algorithms/models via RapidProm from the particular repository: (I am sorry, I was not able to attach items because .rmp files are not supported here. Thus I link to the repository). There are several .rmp files, I ran synthetic and sample_sepsis. 

Once I run sample-sepsis (from the folder Workflows), it ends up with "Process failed. Could not initialize class Ipsolve.LpSolve". (attached you find the screenshot of this error). The problem is: that whenever I run Conformance Checking, it happens. 

The second execution of the synthetic (experiments->workflows) fails with: access denied ("java.lang.RuntimePermission""ModifyThread). You can also find the error log as a screenshot (there are 2 of them). 

Please note, in this repository in the folder source code locates one jar file which we put to the user\.RapidMiner\exctensions folder to have additional functionality related to this work.  In the additionally attached README file, the author mentions that we need a professional license to run models.  I acquired a professional license (limited for 1 month) and I thought there is an issue with my educational license (that I had before), but it did not work out. I also restarted my laptop, did not help.

P.S. I attempted running models in RapidMiner on Windows 10 and macOS Catalina, both with java8. 

Could you please share any possible solutions?

Best regards, 

Sign In or Register to comment.