To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Error loading initial packages


I keep getting the following message when I start up ProM 1.2:

Exception in thread "main" java.lang.Exception: Cannot find release package defined in ProM.ini file: LitePackages. Continuing to load ProM.
        at org.processmining.contexts.uitopia.UI.main(

Is there something I can configure? I'm loading the software from a PC at work but I do have admin rights so it shouldn't have too many problems.

Any ideas?




  • Hi,

    Do you have access to the internet from that PC at work?

    The Prom.ini file is a text-based file with some settings for ProM. Among these settings are the PACKAGE_URL (for the URL to the package repository to download packages from) and the  RELEASE_PACKAGE (the package to download and install by default for this release). The download and installation of this default package hAs failed on your PC. The correct settings for both should be as follows:
    # Specifies which package should be installed
    RELEASE_PACKAGE = LitePackages
    # Specifies the URL to the default package repository
    # (default is "")

    You can also try whether you ca view the given URL in your favorite browser.

    Note that the download of ProM Lite 1.2 only contains the ProM famework. (Almost) all ProM plug-ins are contained in ProM packages, which need to be installed first. ProM will install most of these packages for you when you start ProM for the first time, but it needs an active internet connection to do so.

    Kind regards,

  • Hi Eric,

    Thank you for your reply. The above has all been done but the packages are still not loading on initial start-up.

    I've spoken to IT at work and there's no software or firewall that should block the packages. However, when I click the default link the following message appears:

    "A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. 

    This can be caused by:
        Bad or misspelled URL
        Following an invalid link
        Problems with your network connection and/or transient conditions on the Internet

    So it could be something your end? I don't know.

    On my home PC I had to extend some memory through settings but can't find the link anymore. Maybe it's related to that, I'm at a loss for options.



  • hverbeek
    edited June 2019
    Hi Stuart,

    The URL you mention shows the problem. The server ceased to exist years ago. Which version of ProM are you actually using? Given the URL, I guess it should be a Nightly Build, but then an old one.

    Please change the line with the PACKAGE_URL in the ProM.ini file to the following:
    This will cause ProM to use the package repository for the Nightly Build, which contains the most recent releases of the packages.

    Kind regards,

  • Eric,

    That URL is different to the one above. It still doesn't load the packages.

    Looks like I'll be doing process mining in the NHS off of my home lap top.


  • Update:

    The following is now showing for most, if not all, packages in the command line. Any ideas?

    Processing url: file:/C:/Program%20Files%20(x86)/ProM%20Lite%201.2/lib/simmetrics-latest.jar
    Skipping: /C:/Program%20Files%20(x86)/ProM%20Lite%201.2/lib/simmetrics-latest.jar while scanning for plugins.

    Thanks for any help / ideas!
  • Hi Stuart,

    This is not an error message. When starting up, ProM needs to create an inventory of which plug-ins are available. For this reason, when started for the first time, ProM needs to scan all installed jars for plug-ins. To speed up this phase in later runs, this information is cached in the Windows registry (on WIndows machines). If found in the cache, ProM will skip scanning the jar file, which is shown in the output. 

    If you experience problems with plug-ins not being available although the corresponding package is installed, then please have a look at the section "Installing packages" on This also shows how you can removed the cached data. Doing so, will cause ProM to scan all jar files again during the next run.

    Kind regards,
  • Thanks Eric, I'll give it a go.
  • Well, something is working. I've got your 'package overview' but nothing more. I'm stumped.
Sign In or Register to comment.