To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

ProM cannot import logs in xes file format

edited February 2019 in - XESame
Hi all,

I tried to import logs in xes file format but ProM  reported an error. The logs is the example-logs. The error information is as follows :Errors detected while parsing IEEE XES log. Line 23, column 51: Classifier keys [org:resource] are not all gobal(see clause 5.7.2). Line 213, column 7: Log declares the feture for nested attributes ,but does not have any nested attribute (see clause 5.1.2)*w!/b/dLYAAAAAAAAA&bo=pwY4BAAAAAARB60!&rf=viewer_4

My prom version is 6.8 with 64-bit JRE8 and all packages have been loaded in prom package manager. JDK is 1.8.
While I tried to import logs in txt file format , prom ran successfully.

What could be wrong? I'm out of idea here, I would be glad if you could provide some help 

Best regards,


  • Hi Duan,

    There are several plug-in that can import this log, which include:
    • Open XES Log File (Naive)
    • Import Lenient Log from IEEE XES Log File
    As you are using the "Import Conforming Log from IEEE XES Log File" plug-in, any non-conformance issue in the log is treated as an error.

    Some of the example log files predate the IEEE XES standard. As a result, they may not satisfy all requirements of that standard. To import such a log, use an importer which is less strict, like the two mentioned above.

    Kind regards,


  • Hi Eric,

    Thank you for the suggestion provided, my previous question has been resolved. But now I have two new problems, please help me find out.

    The first problem, after I uninstalled ProM, I was reinstalling ProM. The ProM can't automatically download the package, only I can manually download it in the ProM package manager. I have uninstalled it clean and I have not found the reason.

    The second question, I use eclipse to download the svn code. After the download is complete, click the "ProM Package Manager (Workshop).launch" file and select "RunAs". But it prompts an error message:”No package were found. Please check your internet connection“,click the "sure", appear the ProM package manager interface. But no information on the up to date,Out of date,Not installed, Selection interfate. My Eclipse has been installed Subcplise and IvyDE.

    Eclipse console:Plug-in level threshold set to Local
    Plug-in quality threshold set to VeryPoor
    Ini file processed
    >>> Loading packages from C:\Users\user\.ProM\packages\packages.xml
    [PackageConfigPerister] Context URL set to
    >>> All dependencies have been resolved
    Failed to read package in 106 milliseconds.

    What could be wrong? I'm out of idea here, I would be glad if you could provide some help 

    Best regards,

Sign In or Register to comment.