To prevent spam users, you can only post on this forum after registration, which is by invitation. If you want to post on the forum, please send me a mail (h DOT m DOT w DOT verbeek AT tue DOT nl) and I'll send you an invitation in return for an account.

Error in lauching ProM using Eclipse

edited September 2011 in - Development

I tried running ProM 6.0 UITopia using Eclipse, and it gave me this error:

Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.processmining.framework.boot.Boot.boot(
at org.processmining.framework.boot.Boot.boot(
at org.processmining.contexts.uitopia.UI.main(
Caused by: java.lang.IncompatibleClassChangeError: org.processmining.models.graphbased.directed.petrinet.analysis.NetAnalysisInformation and org.processmining.models.graphbased.directed.petrinet.analysis.NetAnalysisInformation$RELAXEDSOUND disagree on InnerClasses attribute
at java.lang.Class.getDeclaringClass(Native Method)
at java.lang.Class.getEnclosingClass(Unknown Source)
at java.lang.Class.getSimpleBinaryName(Unknown Source)
at java.lang.Class.getSimpleName(Unknown Source)
at org.processmining.contexts.uitopia.model.ProMResourceType.<init>(
at org.processmining.contexts.uitopia.hub.ProMResourceManager.addType(
at org.processmining.contexts.uitopia.hub.ProMResourceManager.<init>(
at org.processmining.contexts.uitopia.hub.ProMResourceManager.initialize(
at org.processmining.contexts.uitopia.UIContext.initialize(
at org.processmining.contexts.uitopia.UI.main(
... 7 more

I would appreciate some help if anyone could explain to me what this error is about, and how do I solve it? Thank you for your help!

Edit Joos: Changed category


  • Hi,

    I never encountered this error, but I would have tried the following:

    1. Do a fresh checkout of the source.
    2. Clear the plugin cache and retry running.

    Have you already tried these?


  • Hi PCoder,

    Thanks for the suggestion. I did a fresh ckeckout of the source and deleted the .ProM and the UITopia folder before trying to run it again. It's working now, just that it got stuck every time it tries to download/update its packages (I just cancelled the update and proceed).

    Thank a lot again.

Sign In or Register to comment.